EFT Processing Delays - Banking Partner
Incident Report for VoPay International
Resolved
I am pleased to inform you that the issue has been resolved, and all EFT transactions are now being processed as expected.
Posted Nov 21, 2023 - 05:01 UTC
Monitoring
Our banking partner has identified and resolved the issue. Nevertheless, please be advised that transactions previously submitted might still encounter some processing delays.
Posted Nov 21, 2023 - 00:38 UTC
Investigating
Our banking partner is currently facing technical difficulties with processing EFT transactions, which may result in delays for some transactions.
Posted Nov 20, 2023 - 22:45 UTC
This incident affected: Transaction Processing (EFT Processing).